Something that’s helpful in a development team is sticking to one naming convention. It can be very helpful when one team member needs to modify another team members code. For example, a = b * c makes little sense as opposed to pointTotal = points * quantity. In the early days of programming variable names were kept as small as possible to conserve memory but now in the days of gigs and gigs of space there is no reason to do so. While we should not go overboard we should make our code as descriptive as we can (as well as comment and indent it!).
There are many types of naming conventions. Personally I try to stick to one called Camel Case. The name comes from the uppercase “bumps” in the middle of the compound word, suggestive of the humps of a camel. thisIsAnExample of Camel Case. To me it’s easy to read and remember. For more information on Camel Case please visit the link below: http://en.wikipedia.org/wiki/CamelCase